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 Quick Start Tutorial
The lessons in this tutorial give you the chance to learn Toon Boom Studio using realistic 
examples. 

These self-contained lessons can be completed in any order, this allows you to learn about 
the features that interest you most.

You can download the material for each lesson as a single package at the same location 
where you downloaded this PDF (http://www.toonboom.com/products/
toonBoomStudio/eLearning/tutorials/quickStart/).

Right-click (Windows) or [Ctrl] + click (Mac) on the sample material *.zip file (TBSv5-
QuickStart.zip) and chose to extract the files to a folder somewhere on your computer, 
such as your desktop. You will find seven folders, one for each lesson, with two folders in 
each lesson folder: the final project and the uncompleted (or rough) project which you will 
use to follow the lesson.

This tutorial includes the following lessons:

• Lesson 1: Drawing on page 4

• Lesson 2: Painting on page 13

• Lesson 3: Lip-Synching on page 24

• Lesson 4: Building a Multiplane Scene on page 33

• Lesson 5: Creating Cross-Dissolves with Colour Transform Elements on page 55

• Lesson 6: Creating Clipping Mask Effects on page 66

• Lesson 7: Retouching on page 71



Toon Boom Studio Quick Start Tutorial
Lesson 1: Drawing
In this lesson, you will work with Toon Boom Studio drawing tools to create frame-by-
frame animation. 

There are two animation projects for this lesson:

• Drawing_Rough
• Drawing_Final

You’ll use the Drawing_Rough animation project to complete a walk cycle. You can refer 
to the Drawing_Final project as a reference at anytime throughout this lesson. You’ll use 
the onion skin, rotary light table, and the Toon Boom Studio centre vector line drawing 
tools and pressure-sensitive Brush tool to draw the old man.

               

To start the Drawing lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson1_Drawing > Drawing Rough and open the Drawing_Rough.tbp 
project file inside.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to and use should you want to.

You will draw this pose 
of the old man so he 
fits between the 
previous and next 
frames.

current frame

previous frame next frame
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Lesson 1: Drawing  -    Step 1: Drawing the Old Man’s Head
Step 1: Drawing the Old Man’s Head
In this step, you will draw the head of the old man using the Ellipse tool. Because this 
drawing must fit with the other drawings in the element to create a complete cycle, you 
will use the onion skin to show the previous and next drawings of an element as a 
reference while you draw.

To draw the old man’s head:

1. In the Exposure Sheet window, click the first cell in the rough-oldman element and 
press [S] on your keyboard to move forward (or to the next cell). As you scroll 
through all of the drawings in the rough-oldman element, you’ll notice that there is 
no drawing in the rough-oldman-2 cell. That’s because you are going to draw it! To 
move to the previous cell, use [A].

2. Click in the Drawing View and set it up so that you have a clear view of the old man.
To turn the grid off or on, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold down the [Spacebar] (this 
turns the mouse into the Grabber tool) and click and use the mouse to drag a 
section of the window into view.

3. Select the rough-oldman-2 cell. 

4. In the toolbar, click the Onion Skin button to turn on the onion skin feature. When 
the onion skin is active, the button looks like it is pressed in.

 

If you do not see all the Onion Skin options available, click on the double arrowheads 
>> to view the rest of the toolbar.

5. When you click on the Onion Skin button, the show Previous Drawing  option 

and show Next Drawing  option are selected by default. If you would like to see 
5
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more than just the first previous and next, make a different selection from the 
respective drop-downs now.

In the Drawing View, the previous and next drawings that are made visible by the 
onion skin feature appear pale red for the previous drawing and pale green for the 
next drawing.

6. Select the Ellipse  tool from the Drawing Tools toolbar. 

When you draw with the centreline tools (including Pencil, Rectangle, Ellipse, 
Polyline and Line tools) the Maximum Size value is assigned as the width of the line.
6 



Lesson 1: Drawing  -    Step 1: Drawing the Old Man’s Head
In the Pen tab, you can see that the Maximum Size value is currently set to 20 by 
default. 

7. In the Drawing View, draw an ellipse roughly the shape of the old man’s head. Don’t 
worry about the actual shape not being the same as the one in the animation. You 
will reshape it using the Contour Editor tool in Step 2: Reshaping the Old Man’s 
Head coming up next.

8. Save your animation project using the File > Save command. 

9. Now move on to Step 2: Reshaping the Old Man’s Head.
7



Toon Boom Studio Quick Start Tutorial
Step 2: Reshaping the Old Man’s Head

In this step, you will use the Contour Editor  tool to move the points that make up the 
ellipse you drew in Step 1 in order to reshape the old man’s head.

To reshape the old man’s head:

1. From the Drawing Tools toolbar, select the Contour Editor.

2. Click the ellipse you drew in Step 1. You’ll notice that a line appears down the center 
of the shape (a centreline) and that there are points on this line.

3. Use the Contour Editor to reshape the ellipse by moving the points and dragging 
the Bezier handles. (To get the Bezier handles to appear, click a point on the 
centreline.) 

The final shape should be approximately the same shape as the old man’s head 
shown in the previous drawing.

4. Save your animation project using the File > Save command.

5. Now move on to Step 3: Using the Brush Tool to Draw the Old Man.

After you reshape the ellipse, 
it should look like this
8 



Lesson 1: Drawing  -    Step 3: Using the Brush Tool to Draw the Old Man
Step 3: Using the Brush Tool to Draw the Old Man

In this section, you will use the Brush  tool to draw the old man’s head and then the 
rest of his body.

Unlike the Ellipse tool and other centreline tools (Rectangle, Polyline, Line and Pencil), the 
Brush tool creates variable strokes widths that respond to the pressure you apply with a 
stylus and graphic tablet. 

When you draw with the Brush tool, Toon Boom Studio creates a shape that is formed by 
lines and points that surround a zone filled with colour. We call these shapes created by 
the Brush tool “contour shapes”. 

Drawing with the Brush tool allows you to create distinctive lines that are more natural 
than the mechanical looking centreline shapes. However, due to these extra points, brush 
strokes are heavier and make the file size larger. If you are concerned about the file size of 
your animation, consider this carefully when choosing your drawing tools.

To draw the old man with the Brush tool:

1. Select the Brush  tool from the Drawing Tools toolbar. 

2. In the Pen tab, note that 5 is the Minimum Size value and 20 for the maximum size 
value. When you draw with a graphic tablet and pen, Toon Boom Studio uses the 
Minimum Size and Maximum Size values to determine the width of the variable-
width line.

3. In the Colour Palette, select Colour 9.

Colour 9, a bright, light blue colour, matches the colour of Col-Erase pencils which 
are used by traditional animators to sketch out their rough artwork. A darker colour 
is later used to trace out a clean version. 

4. In the Drawing View, use the Brush tool to draw the old man’s ear. The onion skin 
feature allows you to view the previous drawing which you can use as a reference.

5. Using the Contour Editor tool, click the drawing of the old man’s ear and then 
[Shift]-click the old man’s head. Notice the difference between the number of points 
in old man’s ear, which was drawn using the Brush tool, and the old man’s head, 
which was drawn using the Ellipse tool.
9
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When you have finished comparing the drawings deselect them by clicking anywhere in 
the Drawing View window. 

6. Using the Contour Editor tool and the curve handles, reshape the old man’s ear so 
that it is approximately the same shape as the old man’s ear shown in the previous 
drawing through the onion skin.

7. Draw the rest of the old man. Because we would like the new drawing to fit in the 
walk cycle, draw the old man’s legs so that his left leg is slightly lower than the 
previous drawing and his right leg slightly higher.

A Brush stroke is 
surrounded by a collection 

of points. The outline 
of the brush stroke or 

painted fill is called a 
contour.

A Line drawn using the 
Ellipse tool is defined by 

a series of centreline 
points.

After you reshape 
the ear it should look 

like this
10 



Lesson 1: Drawing  -    Step 3: Using the Brush Tool to Draw the Old Man
When you finish drawing, your old man should look something like this.

You can look at the final drawing in the Drawing_Final animation project to see how we 
did it.

8. Use the Rotary Light Table to turn the image and get a better angle to draw from.
To display the Rotary Light Table, hold down [Ctrl] + [Alt] when using Windows 
or [Ctrl] + [Command] when using Mac OS X. The red animation disc outline 
appears. Continue to hold down these two buttons, then use your mouse or 
stylus to click anywhere in the Drawing view and use it to freely rotate your 
drawing space.

To return your drawing space to the original angle, select View > Reset Rotation 
or press [Shift] + [C].

9. Save your animation project using the File > Save command. 

10. Now move on to Step 4: Previewing the Old Man Cycle, where you will learn to 
playback the animation.
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Step 4: Previewing the Old Man Cycle
In this step, you use the Interactive Playback buttons to preview your drawing of the old 
man and see how it fits into the walk cycle.

To preview the Old Man cycle using Interactive Playback

1. Press the Play  button.

All of the selected content plays in sequential order in the Drawing View window.

2. If you want the playback to cycle, select the Loop  button before you click the 

Play  button.

3. Make corrections to your old man drawing so that the transition between the 
drawings in the cycle looks logical and smooth.

4. Save your animation project using the File > Save command. 

Congratulations on completing this lesson. 
12 



Lesson 2: Painting  -    Step 4: Previewing the Old Man Cycle
Lesson 2: Painting
In this lesson, you will paint the old man to give him some colour. 

There are two animation projects for this lesson:

• Painting_Rough
• Painting_Final

In the Painting_Rough animation project, you’ll build a colour palette for the old man and 
create a gradient colour swatch. Then you’ll paint the old man using Toon Boom Studio’s 
powerful paint features that will speed the painting process.

Refer to the Painting_Final project as a reference at anytime throughout this lesson.

To start the Painting the Old Man lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson2_Drawing > Painting_Rough and open the Painting_Rough.tbp 
project file inside.

2. Save the animation in a location of your choice using File > Save As. 

3. Click the Play  button and watch the old man walk! 

Now it’s time to give the old man some colour and the candle a bit of light!
13
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Step 1: Adding a Colour Swatch
In this step, you’ll add a colour swatch to the old man’s colour palette.

To add a colour swatch:

1. If the Colour Palette window is not open, select Window > Colour Palette, 
otherwise click the Colour Palette tab. 

The Colour Palette tab appears with the default set of colours. 

2. From the Name drop-list, select old man. This is the old man colour palette, which 
you can use to organize all of the colour swatches for this character.

3. You can click the Show/Hide Colour Name button on the right side of the dialog box 
between the Style drop-down and the colour swatches. This changes the display to a 
column of swatches without names to make room for more immediately visible 
swatches.

For this exercise, it is recommended to toggle back to the previous setting to view 
both the name and colour of the swatches.

4. Select the flame lines colour swatch and click the Add a Colour  button. A copy of 
the lines flame swatch appears in the palette style and it is called New 1 by default. 
You will edit the properties of this colour swatch in the next step.

5. Save your animation project using the File > Save command.

6. Now move on to Step 2: Creating a Gradient “Flame” Swatch.

This Colour Palette provides 
all of the colour swatches you 
need to paint with.

The Show Colour Names 
button displays the names of 
the swatches.
14 



Lesson 2: Painting  -    Step 2: Creating a Gradient “Flame” Swatch
Step 2: Creating a Gradient “Flame” Swatch
In this step, you will create a gradient for the candle flame. 

To create a gradient: 

1. Double-click the colour swatch you created from the flame lines swatch. You’ll use 
this swatch as a basis for the gradient so that the flame’s outline and gradient fill 
appear in harmony.

The colour picker opens.

 

2. Select the Gradient option.

3. In the Gradient panel, select Radial. The colours in a radial gradient blend in a 
circular pattern.

Gradient

The look of your colour picker is dependent on 
your operating system.
15



Toon Boom Studio Quick Start Tutorial
4. Click the first marker below the Gradient bar. A square appears in the marker to 
indicate that it is editable.

5. Change the colour of the first marker to yellow by dragging your mouse or stylus in 
the colour picker area. We used these R, G, B values: 248, 251, 17. You can use the 
Colour slider, or enter these values manually.

6. Click below the Gradient bar to add a gradient marker. The colour of the new marker 
is the same colour as the end marker that was currently selected. Gradient markers 
represent the start or end of a transition between different colours.

7. Do one of the following: 
In the Opacity field, type 60 (Mac OS X).
In the Alpha field, type 150 (Windows). 

8. Change the value of the last colour to red.  
You can use these specific values: 236, 0, 0.

9. Rename your swatch to Flame, then close the colour picker window. That’s it, you 
have successfully created a gradient swatch!

10. Save your animation project using the File > Save command. 

11. Now move on to Step 3: Painting the Flame on the Candle.

End colour 
marker

End colour 
marker

Transition 
colour
16 



Lesson 2: Painting  -    Step 3: Painting the Flame on the Candle
Step 3: Painting the Flame on the Candle
Now that you have created a gradient swatch for the flame, you are ready to paint.

To paint the candle’s flame:

1. In the Exposure Sheet, select the first drawing in the ColourMe element   
(ColourMe-1). The old man appears in the Drawing View.

2. Set up the Drawing View window so that you have a clear view of the candle.
To turn off the grid, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold down [Spacebar] and use the 
Grabber tool to navigate your location in the Drawing view.

3. Select the Paint  tool from the Drawing Tools toolbar.

 

4. From the Colour Palette tab, select the gradient swatch you created for the flame.
17
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5. Click the area of the flame inside the lines with the Paint  tool.

 

6. In the Timeline view, scroll through the old man drawings and paint the flame in each 
drawing. 

Press [S] to advance to the next frame and press [A] to return to the previous frame.

You’ll notice that after you paint drawing 2, you will come to a drawing that has 
already been painted. That’s because we held drawing 2 for two exposures. Each cell 
in the Exposure Sheet (or frame in the Timeline) refers to a drawing in the animation 
project. When a drawing that is repeated is modified, Toon Boom Studio updates all 
cells and frames that reference that drawing.

7. Save your animation project using the File > Save command. 

8. Now move on to Step 4: Editing the Direction of the Flame, where you will change 
the position and length of the flame gradient.
18 



Lesson 2: Painting  -    Step 4: Editing the Direction of the Flame
Step 4: Editing the Direction of the Flame
Now that the candle flame has been painted it requires some minor editing to make it look 
more natural.

Use the Edit Texture  tool to change the position and length of the flame gradient.

To edit the flame in the painted zone:

1. Select the Edit Texture tool from the Drawing Tools toolbar. 

2. With the Edit Texture tool, click the flame gradient in one of the old man drawings. 
The gradient editor appears.

3. Grab the handles to rotate the gradient or change its length. Since you want to 
create an effect that looks natural, experiment with the Edit Texture tool until you 
achieve the desired effect.

                      

4. Save your animation project using the File > Save command. 

5. Now move on to Step 5: Painting the Old Man drawings.

Use the handles to 
reshape the gradient.

Drag the centre of the Gradient 
Editor if you want to change the look 
of the Flame’s gradient colour.
19
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Step 5: Painting the Old Man drawings
In this step, you are going to use Toon Boom Studio’s powerful automatic painting 
features.

Click in a zone in one drawing and let Toon Boom Studio scroll through the rest of the 
drawings in the same element to check if there is a closed zone beneath. If there is a closed 
zone, Toon Boom Studio automatically paints the zone with the same colour.

Another useful feature is the Auto Close Gap. Before you can fill a zone with colour, it has 
to be completely closed. Sometimes when you draw with the Brush tool, you may not fully 
close a zone. While you are painting, you can set a threshold for these line gaps so that 
Toon Boom Studio will paint zones regardless of whether they are completely closed or 
not.

To paint the old man:

1. From the Tools > Auto Close Gap menu, select Close Large Gap. 

2. In the Exposure Sheet window, select the colourMe-1 drawing.

3. Click on the drawing, then press [X] to zoom in on it so that you can see the zones 
more clearly.

4. Select the Paint tool from the Drawing Tools toolbar.

5. In the Colour Palette tab, click the skin colour swatch in the old man colour palette. 
20 



Lesson 2: Painting  -    Step 5: Painting the Old Man drawings
6. Press [Shift] + [Option] in Mac OS X, or [Shift] + [Alt] in Windows, and click the old 
man’s face. Your pointer changes to indicate that the Paint All tool is active.

After it is done, scroll through the drawings to check that the face on all of the drawings 
have been painted with the same skin colour swatch. You may have to manually correct 
some drawings because of where you clicked on the drawing (it might overlap other 
zones, for example). 

7. Continue to use the Paint All tool to colour all the appropriate zones with the old 
man’s skin colour.

               

8. Continue to use the Paint All feature, remembering to select the appropriate colours 
from the old man colour palette (refer to the name of the colour swatch for 
reference), until all the areas of your drawings are coloured.

Click here with the Paint All tool and 
it will paint the same area in all of the 
drawings in the element.
21
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9. Next, paint the smaller zones one at a time. Use the names of the colour swatches to 
identify which zones they belong to on the old man, then click those zones with the 
Paint tool. Each zone will be filled with colour.

                

10. Save your animation project using the File > Save command. 

11. Now move on to Step 6: Export, where you export the animation so that it may be 
shared with others.
22 



Lesson 2: Painting  -    Step 6: Export
Step 6: Export
Now you are ready to export your creation and share it with your friends and family.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play.

Congratulations on completing this lesson! 
23



Toon Boom Studio Quick Start Tutorial
Lesson 3: Lip-Synching
In traditional animation, lip-synching was considered to be the most tedious task in the 
animation process. Before you can even begin to draw the mouth positions, you have to 
analyze the voice track to determine what mouth position best matches the sound at each 
frame. 

With Toon Boom Studio, the easy-to-use lip-sync feature analyzes the sounds in a voice 
track and generates a mouth chart based on the eight animation phonemes. In addition, 
Toon Boom Studio has a tool that will automatically map drawings in an element based on 
the sounds they match. These two tools together will save you hours of time and labour!

There are two animation projects for this lesson:

• Lip_Sync_Rough

• Lip_Sync_Final

You will be asked to use the Lip_Sync_Rough project to complete this lesson. You may 
refer to the Lip-Sync_Final project as a reference at anytime throughout this lesson. 

To start the Lip-Sync lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson3_Drawing > Lip_Sync_Rough and open the Lip_Sync_Rough.tbp 
project file inside.

2. Save the animation to a location of your choice using File > Save As. 

Just look at Deb Ant! So nervous? 

Looks like she’s got something to say.
24 



Lesson 3: Lip-Synching  -    Step 1: Importing Deb Ant’s Voice Track
Step 1: Importing Deb Ant’s Voice Track
In this step, you will import a speech made by Deb while she’s at the Survivor Ant tribal 
council meeting. 

In Toon Boom Studio, you must import sounds into Sound elements so you must add a 
sound element first.

To import Deb Ant’s voice track:

1. Click the Add Sound Element  button at the top of the Exposure Sheet window. 
An empty sound element appears in the exposure sheet. 

2. Select Element > Rename Element and use the Rename Sound Element dialog box 
to name the element debSpeaks. When you are finished, click OK.

3. Right-click (Windows) or [Control]-click (Mac OS X) the first cell in the element and 
select Import Sound File from the pop-up menu. The Open dialog box opens.

4. Browse the Lesson3_LipSync folder and select please_dont.MP3 and click Open. 
The sound file now appears in the cell you selected. 

5. Turn-up your headphones or speakers, [Control]-click (in Mac OS X) or right-click (in 
Windows) the first cell in the debSpeaks element and select Play from the pop-up 
menu. Listen as Deb Ant begs not to be thrown-out of the tribe.

6. Now move on to Step 2: Generating a Mouth Chart for Deb Ant, where you will 
generate a mouth chart to use as a reference for drawing lip shapes.
25
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Step 2: Generating a Mouth Chart for Deb Ant
In this step, you will use Toon Boom Studio to generate a mouth chart that matches Deb 
Ant’s speech to a set of animation phonemes. You can use the mouth chart as a reference 
as you draw the lip-sync images for your characters. 

To generate a mouth chart for a Deb Ant’s voice track:

1. Select the debSpeaks element and select Element > Edit Sound. The Sound 
Element Editor appears.

2. In the Sound Element panel, click the wave form of the sound track and click the 
Streamed checkbox to set up this sound for streaming. 

Voice tracks are best set as streamed sounds because they begin playing before the 
entire sound is loaded and will better maintain synchronization with *.swf images.

3. Select the waveform in the Sound Element panel and click the Lip-Sync button. A 
progress bar appears as Toon Boom Studio analyzes the selected sound clips and 
assigns a mouth chart letter to each frame.

The lip-sync images on the right side of the window become active. Drag the frame 
slider in the Sound Element panel to see the mouth position for each frame of 
sound.

4. Select the Enable Scrubbing option at the bottom of the Sound Element Editor. 
Scrubbing allows you to slowly play the sound forward and backward.

Here’s the 
Streamed 
checkbox.
26 



Lesson 3: Lip-Synching  -    Step 2: Generating a Mouth Chart for Deb Ant
5. Drag the frame slider at the top of the Current Sound panel to “scrub” the sound 
track and hear for yourself the sound that Deb is making at each frame. 

6. Click OK to close the Sound Element Editor and then save your animation project.

7. Save your animation project using the File > Save command. 

8. Now move on to Step 3: Drawing Deb Ant’s Missing Mouths.
27
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Step 3: Drawing Deb Ant’s Missing Mouths
In the sample Lip-Sync lesson, we drew six out of seven of the mouth positions for Deb 
Ant. It is up to you to draw Deb’s mouth for the “D” position using the lip-sync preview 
images.

To draw Deb Ant’s missing mouth shape:

1. In the Exposure Sheet window, press [Ctrl] (Windows) or [Command] (Mac OS X) and 
drag the debSpeaks element so that it is next to the mouth column. This will make it 
easier for you to see the mouth chart while you are working on Deb’s mouth.

2. Right-click (Windows) or [Control]-click (Mac OS X) a cell in the debSpeaks element 
and select Show Lip-sync from the pop-up menu. Toon Boom Studio displays the 
phoneme assigned to each frame in the sound.

3. Click the Toggle Thumbnails button to show the mouth chart.

4. Scroll down the Exposure Sheet window to frame 4 where you will find a blank frame 
in the mouth column labelled mouth-d. Select this frame.

This is the Toggle Thumbnails 
button. Click it and you will see 
preview images for the lip chart you 
computed.

Frame missing a Deb Ant mouth 
drawing.
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5. Now, with the lip-sync preview image as a reference, draw Deb Ant’s mouth in the D 
position. After you have finished drawing her mouth, paint it using the swatches in 
the Deb Ant colour palette under the Colour Palette tab.

This is how Deb Ant’s mouth looks in the D position that we drew.

Here are some tips to help you out:

Set up the Drawing View so that you have a clear view of Deb Ant.
To turn off the grid, press [G], the default keyboard shortcut.
To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold down the [Spacebar] and 
use the Grabber tool to navigate to a different part of the window.

The mouth must fit on Deb Ant’s head. 

You can use the Onion skin  to display the previous and next mouth 
drawings and use these drawings as a reference.

You can use the Auto Light Table  to display drawings from other layers 
in the current frame, including Deb. You will need to hide other elements 
(using the Element List on the left side of the Timeline view) to display only 
selected elements.
You can add a drawing (like the F drawing) to the Static Light Table so that 
you can use it as a reference.
You can copy and paste drawings from previous cells (try the F cell) and 
modify them to suit the mouth position.

Use the Stroke  tool to create an invisible line in order to close an otherwise 
open area.

Use the Close Gap  tool to close smaller holes in the line art, such as the 
zone in the neck, so that you can paint it.

6. Save your animation project using the File > Save command. 

7. Now move on to Step 4: Auto-Mapping Deb Ant’s Mouth to the Voice Track, where 
you will identify each phoneme drawing and auto-map them to the appropriate cells.
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Step 4: Auto-Mapping Deb Ant’s Mouth to the 
Voice Track
In the Lip-Sync Mapping dialog box, you will be asked to identify each phoneme drawing 
for a character and then Toon Boom Studio will automatically label all of the cells in the 
character’s element with the appropriate link for each phoneme drawing.

To make this feature really work for you, it is best if you name your drawings with the seven 
phonemes and the closed mouth position: A, B, C, D, E, F, G, and X.

In the mouth element, we have already named all the elements with the letters of the 
seven plus one phonemes. All you have to do is map the drawings to the phonemes in this 
element, and Toon Boom Studio will do the rest of the work for you. For Deb’s mouth, you 
are going to use the same drawing for the A position and the X position.

To auto-map Deb Ant’s mouth to the voice track:

1. Select the first drawing in the mouth element and click on the arrow keys to scroll 
down the drawings in this element. You’ll see that the mouth positions do not reflect 
the mouth chart that you generated.
30 



Lesson 3: Lip-Synching  -    Step 4: Auto-Mapping Deb Ant’s Mouth to the Voice Track
2.  Right-click (Windows) or [Ctrl] + click (Mac) on the title of the debSpeaks element 
and select Modify Lip-Sync Mapping from the pop-up menu. The Lip-Sync Mapping 
dialog box opens. 

3. From the Destination element drop-down list, select mouth. This is the element that 
you are going to apply the auto-map to.

4. In the X field, type A. For Deb’s mouth, you are going to use the same drawing for 
the A position and the X position.

5. Click OK. The dialog box closes. 

6. If you scroll through the mouth element now, you’ll see that all of the lip drawings 
have been mapped to the phonemes in Deb’s voice track.

7. Save your animation project using the File > Save command. 

8. Now move on to Step 5: Export, where you will learn to export the animation so that 
you can share it with others.
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Step 5: Export
It’s time to export your lip-sync scene.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play.

Congratulations! You have successfully completed this lesson. 
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Lesson 4: Building a Multiplane Scene
One of the great attributes of Toon Boom Studio is the 3D scene space and the camera, 
which allows you to design multiplane moves and cinematic camera effects. 

In this lesson, you’ll create a multiplane camera move that follows the action, as well as 
make the old man cross the room. In the process of all this, you will also get to work a bit 
with templates and smooth moves using the features of your motion paths.

 

There are two animation projects for this lesson:

• Sceneplanning_Rough

• Sceneplanning_Final

You will be asked to work with the Sceneplanning_Rough project to complete this tutorial. 
You may refer to the Sceneplanning_Final project as a reference at anytime throughout 
this lesson.

To start the Building a Multiplane Scene lesson:

1. Go to the Workspace drop-down menu near the top, right corner of the program’s 
window and select Scene Planning.

The entire workspace changes to display the tabs, panels and views most suited to 
plan a scene.

2. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson4_Sceneplanning > Sceneplanning_Rough and open the 
Sceneplanning_Rough.tbp project file inside.

3. Save the animation in a location of your choice using File > Save As. 
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4. Make sure that you are in the Camera and not the default Drawing view.

5. Play back the rough animation by selecting the Play command from the Play menu. 
Not really much to see? Nothing moves, nothing happens except for a ghost 
appearing near the end. 

6. Now move on to Step 1: Attaching the Camera to the Peg to create some more 
interesting visual effects in this scene.
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Step 1: Attaching the Camera to the Peg
The first step in this lesson is to create a camera move using a peg.

The idea of the Toon Boom Studio digital peg system was inspired by traditional 2D cel 
animation. In traditional animation, cycles of animation are typically drawn in-place. To 
make a character’s stationary walk cycle move across the screen, animators will attach the 
cels onto a sliding peg bar at the top of an animation disk. The cels will then be moved in 
measured increments while being photographed. When seen together, this incremental 
photography gives the illusion of a camera pan.

In Toon Boom Studio, you use pegs to create different types of changes over time. In 
addition to motion, you can also create scaling and rotation effects using pegs. 

Toon Boom Studio also features “cameras”, which are like traditional cameras that “film” 
the action in a scene. In Toon Boom Studio, you can combine these two features - cameras 
and pegs - to create camera moves like trucks and pans.

Use one camera and add up to two pegs in your scene or add an unlimited number of 
cameras and pegs to create even more sophisticated scenes. 

For this step, we’ve already created the motion path that the camera will follow and keyed 
these movements onto the peg. All you have to do is attach the camera to the peg. Once 
you have completed this step and activated (checked the boxes) of the Peg-camera and 
Camera layers in the Timeline view, you should see the same motion paths as the ones 
above in your own Top and Side views. 

In the View windows, you can see the elements in your scene from the 
front, side and top:

• Here’s the motion path we created with a peg

• Here’s the camera
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To attach the camera to the peg:

1. In the Timeline view, drag and drop the Camera element on top of the Peg-camera 
element.

The Camera element appears indented below the Peg-camera element to indicate 
that it is attached.

2. Select Play > Play to play back the scene or simply click on the Play  button. 
Watch the camera as it follows the motion path of the peg.

3. Save your animation project using the File > Save command. 

4. Now move on to Step 2: Adding the Old Man Template to the Scene.
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Step 2: Adding the Old Man Template to the 
Scene
Templates are re-usable pieces of animation that you can import multiple times within a 
scene, between different scenes in the same project or into many different animation 
projects. Templates help you by reducing your workload through re-use, by keeping the 
file size of your animations small and facilitate working in a group on the same project. 

For example, you can create a template of a walk cycle and send the template file (with 
the extension *.tbt) to a friend so that they can incorporate it into their animation.

You can create templates out of anything you draw or import into Toon Boom Studio - 
vector drawings, bitmaps, entire elements, groups of elements, sound or SWF files. With 
a template, you have a package of all the objects, making it easy to transport and manage. 
If you create templates from multiple elements, Toon Boom Studio even maintains timing 
(exposure) and layout information with the templates.

We created a template of the walk cycle of the painted old man. All you have to do is to 
drag it into the Timeline or Camera view and you will have added it to your scene.

To add the old man template to the scene:

1. If it is not already open, go to the top menu and select Window > Library to open 
the Library window. The Library window is your centre for Toon Boom Studio content 
management.

From the Library window, you can use:

• The Animation folder to access all 
of the vector drawings in your 
animation.

• The Local folder to manage all of 
the templates in your current 
animation project. Local templates 
are available to the current 
animation project only.

• The Global folder to manage all of 
the templates on your system. 
Global templates are available to all 
animation projects on your system.
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2. Open the Local folder, double-click the old man walk cycle.tbt file and click the 
Play  button in the Library window’s preview panel. Now watch as the old man 
walks in-place.

3. Drag the old man template file, from the Library window to the Timeline view. Drop it 
just under the plant_OL element in the list. 

  

4. Save your animation project using the File > Save command. 

5. Now move on to Step 3: Adding and Attaching a Peg to the Old Man, where you will 
start to create a peg for the old man, so that you can give him some motion.

This is the Library Preview 
panel.
38 



Lesson 4: Building a Multiplane Scene  -    Step 3: Adding and Attaching a Peg to the Old Man
Step 3: Adding and Attaching a Peg to the Old 
Man 
This is the first step to creating a motion path for the old man. 

To add a peg and attach the old man to it:

1. In the Timeline view, select the old man walk cycle element.

2. Click the Add Parent Peg  button at the top of the Timeline view. This will add a 
Peg element to your animation and attach the old man walk cycle element as its child 
automatically. 

3. With the new Peg selected, from the top menu, select Element > Rename Element 
to open the Rename Peg Element dialog box. Change the name of the peg to Peg-
oldman. 
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4. Click OK to confirm the name change.

5. Save your animation project using the File > Save command. 

6. Now move on to Step 4: Creating a Motion Path for the Old Man, where you will 
create a motion path so that the old man can walk across the room.
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Step 4: Creating a Motion Path for the Old Man
This is the biggest step in this lesson. In this step you will get to do something a bit more 
challenging - you’re going to make a motion path with the peg you just added. This 
motion path will move the old man from the left to right across the stage.

You will use three Sceneplanning view windows to design and play back your motion 
effect.

To create a motion path:

1. Advance the red playhead at the top of the Timeline view to frame 1, where the old 
man peg will start.

 

2. In the Timeline view, select the Peg element you just added and the Show/Hide  
button at the top of the window so that no elements are showing. 

3. Click the checkboxes next to the Peg-oldman and Camera layer so that only they are 
displayed. 
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At this point, your peg is just a red circle at the centre of the Top View and Side 
View windows.

Your Top and Side View windows will look something like this. You may have to zoom 
and pan your windows to get the same views as seen in these windows.
• To pan a window, press [Spacebar] and use the Grabber tool to move your view 

of the window.
• To zoom in, press [X].

• To zoom out, press [Z].
• To reset the view, press [Shift] + [V].

4. Make sure you have the Peg-oldman element selected in the Timeline view and 
select Tools > Sceneplanning Tools > Motion to activate the Motion tool or simply 

click on the Motion tool  button.
 

5. In the Timeline view, check the old man walk cycle layer so that he now appears in 
the Camera view. 

6. With the Motion tool, drag the centre of the peg’s red circle around the Camera view 
and observe the simultaneous movement of the peg in the Top or Side Views. If you 
move your Old Man in the Top view, you might risk moving him behind the 
background by accident, therefore it is best for now to work within the Camera view.

Use the Show/Hide 
checkboxes to display 
the elements
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7. In the Camera view, click and drag the peg to the left side of the screen, just before 
the edge of the camera frame.
• In the Side View window, the peg should stay in the middle as shown.

 
• In the Top View window, the peg moves to the inside, west side of the camera 

cone.

In the Timeline view, a keyframe is automatically created on the first frame of the 
Peg-oldman layer. 
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8. In the Timeline view, drag the red playhead to the last frame and use the shortcut [i] 
to add a keyframe there. 

9. Your Old Man might have disappeared from your Camera view. Zoom out by using 
the short-cut [Z] to find him again. He should be hiding on the left side. 

10. With the Motion  tool in the Camera view, drag the Old Man’s peg (red circle) 
towards the right of the camera frame and release it when it is just outside. You could 
also do the same in the Top view. If you want, drag the last keyframe on the motion 
path (which is on the right) towards the east side of the camera cone.

You should now see two 
keyframes appear on 
the peg.

• The first keyframe 
is on the left.

• The last keyframe 
is on the right.
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Both actions will produce the same result, as long at you keep the path in the Top 
view straight. If it is dragged diagonally, it may disappear behind the background.

 

11. Click the Loop  button in the Playback toolbar, then click Play  to preview 
your work in the Camera view.

12. Save your animation project using the File > Save command. 

13. Now move on to Step 5: Creating a Multi-plane Scene.
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Step 5: Creating a Multi-plane Scene
In this step, you will learn how to push drawing elements, such as the plant overlay and 
the background, either backwards or forwards in space to create the illusion of depth.

To pull the plant overlay forward in space:

1. In the Timeline view, move the red playhead back to frame 1.

2. In Timeline view, select the plant_OL layer.

In the Camera view, you should see a blue, rectangular bounding box around the 
plant. In the Top and Side views, the plant should appear as a darker green line. 

All drawing elements appear as thin, green lines in the Scene planning views to 
represent their true 2D appearance in 3D space. Their widths vary, depending on 
how wide they actually are in the Camera view.

3. In the Top view, use the Reposition All Drawings  tool to select and drag the 
plant_OL down towards the taper of the camera cone. In the Side view, you will 
notice the plant_OL moves forward simultaneously. Once it has been moved, the z-
depth value should be around 1.5 F (Forward). You can view this in the Properties 
panel (third field in the Offset section). 

 
You always have the option to type in a given value directly into this field instead of 
moving the drawing element manually. 1.5 is actually quite a large increment, 
especially when dealing with the body parts of a cut-out character. Usually the values 
are “nudged” (increased or decreased) by 0.01 F, B (backward) or -0.01 F (which 
equals 0.01 B).
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To push the background back in space:

1. In Timeline view, select the bg_clean layer.

In the Camera view, you should see a blue, rectangular bounding box around the 
background. In the Top and Side views, the background should appear as a darker 
green line. Note how it is both wider in the Top view and taller in the Side view than 
the plant_OL. 

2. In the Properties panel, in the last Offset field, type in the value 0.5 B.

3. Click the Show/Hide view button to show all the elements, except the peg elements, 
in the Camera view.

4. Click the Loop  button in the Playback toolbar, then click Play  to preview 
your work in the Camera view.

Notice how the camera movement now seems to move forward in depth thanks to 
the varying distributions of the drawing elements along the scene plane.

5. Save your animation project using the File > Save command. 

6. Now move on to Step 6: Creating a Motion Path for the Ghost.
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Step 6: Creating a Motion Path for the Ghost
Now is the time to add a little bit of atmosphere to our scene, we will introduce a ghost 
into the room. This also gives the old man a reason for moving so carefully down the 
corridor.

1. Create a new peg for the ghost.

2. Rename the peg by double-clicking on the layer name and typing Peg-ghost into 
the field.

3. Check the show/hide boxes on all but the Peg-ghost, ghost and Camera layers so 
that they appear again in the Camera view.

4. Make sure that the Peg-ghost layer remains selected.

5. Advance the red playhead at the top of the Timeline window to frame 110, where 
the ghost peg will start.
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6. In the Timeline view, select the first frame of the ghost’s peg and then in the Camera 

view, use the Motion  tool to place the ghost outside of the camera frame.

7. Advance the red playhead at the top of the Timeline view to frame 145, where the 
ghost peg will end.
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8. Use the motion tool to drag the ghost outside of the scene so that it crosses the 
screen.

9. Hold [Shift] and click the middle of the motion path for a motion point to be added 
to the path as a green dot. Next, click and drag the green motion point to create a  
V-shaped path.
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10. Click on the green motion point to change the information in the properties window. 
You can now change the tension to -1 for the V-shaped motion path to be changed 
to a round-shaped path.
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11. Select the first keyframe of the ghost’s peg in the Timeline view by clicking on it. 
This will cause the information in the Properties window to change.

12. Activate the option Orient to Path. The ghost will now follow the path, creating a 
much smoother animation.

  

13. Click the Show/Hide  button to show all elements in your animation, or just verify 
that all the appropriate elements are visible. Then select Play > Quick Preview. This 
command renders your final animation so that you can play it back in real-time.
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14. Use the Playback window to watch the old man walk across the room as the ghost 
passes quickly by.

15. After previewing your animation, tweak the elements where necessary, for example if 
the ghost does not pass low enough or for long enough in the scene.

You can also go a step further with the ghost and not just bend his peg path on a 2D 
plane, but also on a 3D, so that it appears as if he is coming straight towards the 
camera. Examine the ghost-P layer in Sceneplanning_Final.tbp in the Top and Side 
views for further details.

16. Save your animation project using the File > Save command. 

17. Now move on to Step 6: Export, where you will learn to export the animation so that 
you can share it with others.
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Step 6: Export
Well, you have successfully created a multiplane camera move and motion path. Now it’s 
time to package your creation so that you can share it with friends and family!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play.

Congratulations! You have successfully completed this lesson. 
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Lesson 5: Creating Cross-Dissolves with 
Colour Transform Elements

Toon Boom Studio includes a Colour Transform element, which you can use to change the 
colour properties of an element over time. 

In this lesson scene, a skater does some fancy tricks on a half-pipe. To accentuate his 
daring board work, you will use a Colour Transform element to create a series of cross-
dissolves that change the transparency of the skater at different frames.

There are two animation projects for this lesson:

• ColourFX_rough
• ColourFX_Final

You will use the ColourFX_Rough animation project to follow the steps in the lesson. When 
you have questions that you are not sure about, you can refer to ColourFX_Final to see 
how we did it. 

You will work mostly in the Timeline window 
to add and modify Colour Transform 
elements to create cross-dissolves.
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To start the Creating Colour Effects lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson5_ColourFX > ColourFX_Rough and open the ColourFX_Rough.tbp 
project file inside.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to should you want to.

3. Select Play > Play to play back the rough animation. 

Notice how two images of the skater appear to overlap for several frames? Well, in 
this lesson, you are going to make the overlapping images fade-in and out to create 
a series of cross-dissolves.
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Step 1: Adding the First Colour Transform Element
To change the colour of a drawing or image over time, attach it to a Colour Transform 
element and then use this element to specify how the colours in the image or drawing 
attached will change.

In the cross-dissolve that you will create, two drawings will appear at the same time, one 
fades in while the other fades out. To achieve this effect, we placed each drawing on a 
separate layer so that you can control them independently. You’ll see as we progress 
through the lesson how this enables you to create a cross-dissolves.

To add the first colour transform element:

1. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

2. From the Type menu, select Colour Transform Effect.

3. In the Name field, type skateColour and click OK. A new element layer appears in 
the Timeline window.

4. In the layers list on the left-side of the Timeline window, attach the Colour 
Transform-skateColour element to the SkatePeg2 element by dragging and 
dropping it just below the peg.

We have put the 
drawings for the 
skater in 
different 
elements so that 
we can create 
the cross-
dissolve effect.
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5. Attach the sk_2 element to the Colour Transform-skateColour element by dragging 
and dropping it on top of the effects element. 

 

6. Change the start and duration of the Colour Transform-skateColour element so that 
it matches the start and duration of the sk_2 element.

Double-click the trackbar of the Colour Transform-skateColour element to 
select it and drag it to frame 12.

 
Drag the end of the trackbar so that it ends on the same frame as the sk_2 
element (frame 20).

 

7. Save your animation project using the File > Save command. 

8. Now move on to Step 2: Adding Keyframes and Setting their Values.
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Step 2: Adding Keyframes and Setting their Values
In the first Colour Transform effect, the drawing should fade out from frame 16 to 20. 

To achieve this, you must add a keyframe at frame 16. Then, at the keyframe on frame 20, 
you must make the attached elements completely transparent.

With colour transforms, you can chose to do an additive or a multiplicative colour 
transform. 

• In additive colour transformations, a selected colour value is added to all of the 
colours on a layer. For example, you could add a blue-purple to all of your layer 
elements to create a nighttime transformation.

• In multiplicative colour transformations, a selected value (usually between 0 and 
1) is multiplied to all of the colours on a layer. For example, if you wanted a ghost 
to gradually vanish, you could multiply its colours over time with a value less than 
zero.

The effect that you want to create in this lesson is an even transformation of the alpha 
value (transparency), so for your purposes you will choose multiplicative colour options. 

To make an element change from transparent to opaque to transparent, you must multiply 
the alpha values by 0, 1, and 0. When you multiply an opaque colour (255 alpha) by 0, the 
result is 0 which makes the colour transparent.

To add a keyframe and set its value:

1. Advance the red playhead at the top of the Timeline window to frame 16.
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2. From the element list on the left-side of the Timeline window, select the Colour 
Transform-skateColour element. Notice in the Properties window (Window > 
Properties) that the Colour Transform tab opens.

3. In the Colour Transform tab, click the Add  button to add a keyframe to the 
selected frame on the Colour Transform-skateColour element. 

4. Advance the red playhead at the top of the Timeline window to frame 20. 

5. On the Colour Transform tab, drag the Alpha slider in the Multiplicative section of 
the tab all the way to the left. The value should appear as 0 in the Alpha field.

6. Drag the red playhead at the top of the window from frame 12 to 20 and watch as 
the element fades-out.

7. Save your animation project using the File > Save command.

8. Now move on to Step 3: Creating the Next Colour Transform Effect.

A square appears in the 
Timeline to identify the 
keyframe on the trackbar.
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Step 3: Creating the Next Colour Transform Effect
In this step, you are going to create another colour transform effect, for the next element 
in the series, that will go from transparent to opaque to transparent. To achieve this effect, 
you will add a Colour Transform element, set three keyframes, and multiply the alpha value 
at each keyframe by 0, 1, and 0.

To create the next colour transform effect:

1. Add a Colour Transform element and name it skateColour2.

2. Drag and drop the Colour Transform-skateColour2 element just before the sk_3 
layer in the layers list. This will also attach it to the SkatePeg 2 element.

3. Attach the sk_3 element to the Colour Transform-skateColour2 element. 

4. Change the start frame of the Colour Transform-skateColour2 element so that it 
matches the sk_3 element. Start frame: 16; End frame: 24.

5. Add a keyframe to the Colour Transform-skateColour2 element at frame 20. Your 
Timeline window should now look something like this:

6. In the Colour Transform tab, set the keyframes to these multiplicative alpha values:
Frame 16: 0
Frame 20: 1
Frame 24: 0

7. Drag the red playhead from frame 16 to 24 and watch how the first element fades 
out as the second one fades in and then out again. 

You’ll notice how the drawing in the next element appears for the last five frames. In 
the next step you’ll use the exact same colour transform element to fix all of the 
other layers so that they undergo the same colour transform effect.

8. Save your animation project using the File > Save command. Now move on to 
Step 4: Cloning the Colour Transform Effect.
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Step 4: Cloning the Colour Transform Effect
All of the remaining elements, except for the last, must undergo the same colour 
transform effect as you created in Step 3. Rather than duplicating your efforts, you can just 
clone the Colour Transform element and attach the other elements to it. 

When you clone a Colour Transform element, all of the information stored in the effect are 
duplicated so that you do not have to re-create keyframes or their values. If you update 
any one clone with a new value, Toon Boom Studio will update all the other clones with 
this new value.

To clone the colour transform effect, follow these steps:

1. In the Timeline window, select the Colour Transform-skateColour2 element.

2. Select Element > Clone Element. Toon Boom Studio creates a new element and 
names it Colour Transform-skateColour2(1) and renames the original element 
Colour Transform-skateColour2(0). The new element appears at the top of the 
element list in the Timeline view.

3. Attach Colour Transform-skateColour2(1) to the SkatePeg2 element and attach the 
sk_4 element to Colour Transform-skateColour2(1).

4. Drag the ends of the colour transform element so that its start/end frames match the 
layer you want it to transform.

5. Repeat the previous steps for the elements sk_4 to sk_7. Make sure that as you 
attach the skater elements to the Colour Transform elements that you maintain their 
layer order in the layers list.

When you are done, your Timeline window should look like this.

6. Press the Play  button to playback your rough animation.
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Now all you have to do is create the effect for the last layer in the series and the 
effect chain will be complete!

7. Save your animation project using the File > Save command or click on the Save  
button. 

8. Now move on to Step 5: Creating the Last Colour Transform.
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Step 5: Creating the Last Colour Transform
Now, all that is left is the colour transform for the last element that makes up the skater.

For the last colour transform effect, the skater will start out transparent, become fully 
opaque and remain opaque for the rest of the scene.

To create this effect, you will add one keyframe to a Colour Transform element, give the 
first keyframe a multiplicative alpha value of 0 and give the second keyframe a 
multiplicative alpha value of 1.

This step is basically the reverse of step 2, in which you made the character start opaque 
and then end transparent.

To create the last colour transform:

1. Add a Colour Transform element and name it skateColour3.

2. Attach the Colour Transform-skateColour3 element to the SkatePeg2 element and 
attach the sk_8 layer to the Colour Transform-skateColour3 element. 

3. Change the duration of the Colour Transform-skateColour3 element to 9 frames 
and make the element start on frame 36 by clicking and dragging the bar of orange 
frames down the Timeline.

4. Add a keyframe to frame 40 of the Colour Transform-skateColour3 element.Your 
Timeline view will look something like this:

5. In the Colour Transform tab, set the keyframes on the colour transform element to 
the following multiplicative alpha values:

Frame 36: 0
Frame 40: 1

6. Save your animation project using the File > Save command. 

7. Now move on to Step 6: Export, where you will learn to export the animation so you 
can share it with others.
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Step 6: Export
That’s it! You’ve created a pretty nifty colour transform effect with one of Toon Boom 
Studio’s latest effects. All that is left to do is to export your animation and watch it play!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play. 

If you had any trouble with this lesson, check out the Colour_FX_final animation 
project to view a completed version of the project.

Congratulations! You have successfully completed this lesson. 
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Lesson 6: Creating Clipping Mask Effects
Toon Boom Studio comes with the Clipping Effect, an effect which you can use to mask 
out or reveal part of an image. 

In this lesson, you will merge two extreme sports sequences (mountain biking and surfing) 
using a mask to reveal the second scene. While you work on this effect, we hope you learn 
some other things too!

There are two animation projects for this lesson:

• MaskFX_Rough

• MaskFX_Final

You will use the MaskFX_Rough animation project to follow the steps in the lesson. You 
can refer to MaskFX_Final to see how we did it if you are unsure. 

To start the Creating Clipping Mask Effects lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson6_MaskFX > MaskFX_Rough and open the MaskFX_Rough.tbp 
project file inside.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to should you need to.

3. From the Top menu, select Play > Play to play back the rough animation or press the 

Play  button. 

Notice how the two scenes - the one of the biker and the other of the surfer - just run 
into each other? In this lesson, we’ll create a transition between these two scenes 
using a clipping mask in the shape of a wave. To see a completed version of this 
project take a look at the final animation project, MaskFX_Final.

See the wave hot on the trail of 
the biker? 

That is created by a mask in 
the shape of the wave, which 
reveals the image of a wave 
beneath it.
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Step 1: Drawing the Mask
Like the masks worn by children on Halloween, a Toon Boom Studio mask reveals certain 
visual elements while hiding others (like a Halloween mask reveals the eyes of the wearer, 
while covering most of the face).

For the first step in the creation of the mask effect, you must draw the mask that will open 
a window for image(s) beneath it. You can only create masks from vector drawings.

We have already drawn a mask for you. The mask consists of a cycle of vector drawings of 
a wave, which will cut out an image of rolling waves beneath it. Take a look at the mask we 
drew so that you can get a better idea of how it will be used. 

To preview the mask animation that we created:

1. Go to the Drawing view, then in the Timeline view, click on the wave_mask layer.

2. From the Top menu, Select Play > Play to play back the selection or press the  

Play  button. 

Notice how the wave cycle is a collection of painted vector drawings. The painted 
areas of these drawings will be like the holes in the Halloween mask that will let the 
images below it show through.

3. Now move on to Step 2: Building the Clipping Element.

With the onion skin on, you can 
see the cycle of drawings that fit 
together to make the mask.
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Step 2: Building the Clipping Element
After you have created the vector drawings that will act as your mask, or in this case, have 
seen the vector drawings that will act as the mask, you are ready to add the Clipping 
Effect.

A Clipping Effect element consists of two parts: the clipping element and the mask. 

• To the Clipping layer, you attach the elements that you want to show through the 
mask.

• To the Mask, you attach the vector drawing element that you want to use as a 
mask.

You will notice in our setup in the MaskFX_Final scene, that we have attached the 
wave_mask vector element to a peg, that moves the wave in the scene.

To build the mask element:

1. If it is not already visible, click the Show/Hide checkbox next to the wave_mask 
element so that you can see it.

2. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

3. From the Type drop-down list, select Clipping Effect, then type waveEffect in the 
name field and click OK.

Clipping layer

Mask

Vector element attached to the peg

Drawing that will “show through” the mask
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4. Drag and drop the Peg element on top of the Mask layer. When you drag the Peg 
element, the vector element attached to it will move with it as well. You have now 
created the mask!

 

5. Drag the wave.swf Media element on top of the Clipping-waveEffect layer. The clip 
layers appear below the mask layers, but are indented out from the mask layers.

 

6. Save your animation project using the File > Save command. 

7. Now move on to Step 3: Export, where you will learn how to export the animation so 
that you can share it with others.
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Step 3: Export
Now that you have created a Clipping mask effect, you are ready to export and show the 
world the fruits of your labour!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play.

Congratulations! You have successfully completed this lesson. 
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Lesson 7: Retouching
Toon Boom Studio makes it possible to retouch drawings accurately and easily by allowing 
you to see how drawings in different elements work together when animated.

There are two animation projects for this lesson:

• Retouching_Rough

• Retouching_Final

You will use the Retouching_Rough animation project to follow the steps in this lesson. 
When you have questions that you are not sure about, you can refer to Retouching_Final 
to see what we did to put the final scene together. 

To start the “Retouching Drawings” lesson:

1. In the Quick Start Sample Material folder that you downloaded, go to the folder 
called Lesson7_Retouching > Retouching_Rough and open the 
Retouching_Rough.tbp project file inside.

2. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original to 
return to should you need to.

You are now ready to begin working on the sample scene.

Over the duration of the sample scene, Tania 
bends her arm. The joints at her shoulder and 
elbow rotate to create the bending motion.

In this tutorial, you will use “Retouching” to fix 
gaps that appear at the elbow and shoulder as a 
result of the bending action.
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Step 1: Playing Back the Scene
In this step, you will play back the rough scene to identify problems that arise from the 
rotation of the joints in the shoulder and elbow.

To play back the scene:

1. Check that you are in the Camera view by clicking on the camera view icon on the 
top right-side of the Drawing view space.

 

2. Click the Loop  button in the toolbar, then click Play .

When you have finished studying the character’s movement, click Stop 

3. Look closely at the shoulder and elbow as the animation plays back. Press [X] to 
zoom in to the image. Press [Spacebar] and use the Grabber to pan within the 

Click the white space 
to remove the 
selection frame.
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Camera view in order to bring the left side of Tania’s body to the centre of the 
window.

4. Click Stop  to stop the playback. 

5. Now move on to Step 2: Retouching the Elbow Joint, where you will learn to use the 
Brush tool to retouch the line art on the elbow joint.

Note the gap that appears at the 
shoulder joint.

Note the gap that appears in the line art 
at the elbow.

You will fix both of these problems in the 
following steps.
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Step 2: Retouching the Elbow Joint
In this step, you will use the Brush tool to retouch the line art on the elbow joint.

You must select the drawing layer, the frame that contains the drawing you want to 
retouch, and the drawing tool. You can draw directly in the Camera View window.

All elements that are shown in the Timeline view will appear in the Camera view.

To retouch the elbow joint:

1. In the Timeline window, select the “forearm left” layer.

2. Drag the red playhead to frame 15 in the scene. At frame 15, the gap between the 
upper arm and forearm is the greatest. Correcting the drawing at this frame should 
fix the error for the duration of the animation.

3. From the Drawing Tools toolbar, select the Brush  tool.
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As soon as you activate one of the drawing tools, you enter “Edit Drawing” mode.

4. Set up your drawing space so that you can work on the elbow.
If you wish to turn off the grid in the Camera View, press [G] to turn it off.
To zoom in, press [X].
To pan the window, press [Spacebar] and drag the part of the image that you 
wish to work on to the centre.
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5. In the Properties window, click the Pen tab, set your Minimum Size to 4 and the 
Maximum Size to 6. If the Pen tab is not visible, go to the Top menu and select 
Window > Pen.

6. From the Colour Palette tab, select the “line” swatch from the “tania” palette. If the 
Colour Palette is not visible, go to the Top menu and select Window > Colour 
Palette.
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7. Use the Brush tool to connect the stroke on the forearm to the stroke on the upper 
arm.

8. Click Play  and watch the elbow as it bends. If there are any problems with your 

retouches, undo what you did and try again. Click Stop  to stop the playback 
before you try to redo your work. 

9. Now move on to Step 3: Creating the Shoulder Joint, where you will learn to make a 
shoulder joint.
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Step 3: Creating the Shoulder Joint
That was a simple retouch example. The next fix is a little bit more challenging.

In the shoulder, the gap between the shoulder and the upper arm is large. In this step, you 
will practice a technique that will help you in animating all future cut-out characters with 
moveable joints.

To fix the hole between the torso and the upper arm, you will create a perfect circle that 
will act as the joint on which your upper arm will rotate. The circle will overlap the upper 
arm and torso so that no gaps will appear while the joint rotates. You can try this technique 
with other jointed characters you create.

To create the shoulder joint:

1. In the Timeline window, select the upper arm element and move the red playhead 
to frame 1.

2. Zoom and pan the Camera View window so that you have a close-up view of Tania’s 
left shoulder.

3. From the Drawing Tools toolbar, select the Ellipse  tool. 

4. In the Properties window, click on the Pen tab and change the Maximum Size value 
to 6.

5. Click on the Colour Palette tab, select a red colour swatch from the Default palette. 

You will draw the circle with red, and not the colour of Tania’s shirt, so that you can 
easily see the edges of the circle, which will help you position it. After you position 
the circle, you will paint it with the colour of Tania’s shirt and delete the red line art of 
the original circle.
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6. In the Camera View window, press [Shift] to draw a perfect circle and then use the 

Select  tool to click on the red line of the circle and position it in the gap that is 
the shoulder.

7. Press [Esc] to release the selected circle.

8. Click on the Colour Palette tab and select the “shirt” swatch from the “tania” 
palette.
79



Toon Boom Studio Quick Start Tutorial
9. From the Drawing Tools toolbar, select the Paint  tool and click inside the red 
circle to fill it with the “shirt” colour.

10. With the Select  tool, select the red line art around the circle and delete it.

11. Click Play  and watch the shoulder as it bends. If there are any problems in your 

joint, undo what you did and try again. Click Stop  to stop the playback before 
you try to redo your work. 

12. Now move on to Step 4: Retouching the Shoulder, where you will learn to add the 
line art that will cover the joint.
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Step 4: Retouching the Shoulder
After you have created the joint that will fill the gap between the torso and the upper arm, 
you have to add the line art that will cover the joint.

To retouch the shoulder:

1. In the Timeline window, select the “upper arm” element.

2. Drag the red playhead to the first frame in the scene. At frame 1, the gap between 
the torso and the upper arm is at its greatest. Correcting the drawing at this frame 
should fix the error for the rest of the animation.

3. From the Drawing Tools toolbar, select the Brush  tool. 

4. From the Properties window, click the Colour Palette tab, select the “line” swatch 
from the “tania” palette.

5. Use the Brush tool to draw the line art over the shoulder.

6. Click Play  and watch the shoulder. If there are any problems in your line art, 

undo what you did and try again. Click Stop  to stop the playback before you try 
to redo your work.

7. Save your animation project using the File > Save command. 

8. Now move on to Step 5: Export, where you will learn to export the animation so that 
you can share it with others.
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Step 5: Export
Export your scene and show others what you can do with the “Retouching” tips.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. Click the Browse button to the right of the Save As field to bring up the browser 
window and select a location on your computer where you would like to save your 
movie.

3. Name your movie in the browser and click Save when you are done.

4. From the Export Format menu, select the format of your choice. We selected Flash 
Movie.

5. Select Default from the Export Settings menu. 

6. Select Full Movie from the Export Type panel.

7. Select the Launch Player After Export option.

8. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export.

When the export process is complete the movie file automatically opens and starts 
to play.

Congratulations! You have successfully completed the tutorial.
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